Ассоциация ЭБНИТ    ИРБИС-корпорация    Вики-Ирбис    Online/CHM справка Ирбис    FTP-сервер
АРМ Каталогизатор :  ИРБИС Irbis
 
Не пополняется словарь в поле 606
Пользователь: Alt (IP-адрес скрыт)
Дата: 26, January, 2015 14:19

Доброго времени суток. Во вкладке систематизация, в поле 606, в предметной рубрике не пополняются словари. Они формируются добавлением данных, однако после внесения выбор все равно отсутствует. В чем может крыться причина?

Вложения: 01.jpg (249.8KB)  
Re: Не пополняется словарь в поле 606
Пользователь: Яковлева Татьяна (IP-адрес скрыт)
Дата: 26, January, 2015 15:26

Дело в том, что Вы работаете в БД CMPL. В этой базе нет словаря предметных рубрик, здесь только можно подключить словарь предметных рубрик БД ЭК

Re: Не пополняется словарь в поле 606
Пользователь: Alt (IP-адрес скрыт)
Дата: 26, January, 2015 15:41

Подскажите, пожалуйста, каким образом это можно сделать? (и, если необходимо, в каких файлах можно найти данные словари, чтобы обновить их из предыдущей версии)

Re: Не пополняется словарь в поле 606
Пользователь: Яковлева Татьяна (IP-адрес скрыт)
Дата: 26, January, 2015 15:48

Этот словарь есть только в БД ЭК. Возьмите для директории БД CMPL файл pr31.wss

Вложения: PR31.WSS (2.5KB)  
Re: Не пополняется словарь в поле 606
Пользователь: Alt (IP-адрес скрыт)
Дата: 28, January, 2015 09:09

Скопировал этот файл из Deposit и вставил в каталог CMPL. После чего (на всякий случай) пресоздал словарь полностью. Не помогло...

Подскажите, что я сделал не так

Re: Не пополняется словарь в поле 606
Пользователь: Яковлева Татьяна (IP-адрес скрыт)
Дата: 28, January, 2015 10:13

В настройке укажите имя БД ЭК

Re: Не пополняется словарь в поле 606
Пользователь: Alt (IP-адрес скрыт)
Дата: 28, January, 2015 10:23

Неловко уточнять, но можно бы поподробнее описать процедуру? Где и какая настройка?

Не так давно осваиваю систему и мне тяжело на вскидку улавливать столь короткие фразы.

Re: Не пополняется словарь в поле 606
Пользователь: Яковлева Татьяна (IP-адрес скрыт)
Дата: 28, January, 2015 10:32

В режиме Сервис есть настройка параметров

Re: Не пополняется словарь в поле 606
Пользователь: Alt (IP-адрес скрыт)
Дата: 28, January, 2015 13:00

Если вы имеете ввиду: "Каталогизатор -> Сервис -> Настройка параметров -> БД ЭК для заимствованных данных", то там пустой список...

Re: Не пополняется словарь в поле 606
Пользователь: Яковлева Татьяна (IP-адрес скрыт)
Дата: 28, January, 2015 13:28

Напишите сами имя БД ЭК

Re: Не пополняется словарь в поле 606
Пользователь: Alt (IP-адрес скрыт)
Дата: 28, January, 2015 13:36

Там было вписано IBIS, пробовал менять вручную на ATHRA, ATHRC, ATHRS (Как я понял, именно эти базы нужны). С перезапуском Каталогизатора, на всякий случай. Все равно поле 606 остается пустым.

Re: Не пополняется словарь в поле 606
Пользователь: Яковлева Татьяна (IP-адрес скрыт)
Дата: 28, January, 2015 13:52

Нет, эти базы не нужны. Если у Вас БД ЭK - IBIS, то задайте IBIS.

Re: Не пополняется словарь в поле 606
Пользователь: Alt (IP-адрес скрыт)
Дата: 28, January, 2015 14:12

Это значение было по умолчанию. Вернул обратно. Никакого результата.Снимки экрана прилагаются..

Вложения: 11.jpg (246.6KB)   22.jpg (243.1KB)  
Re: Не пополняется словарь в поле 606
Пользователь: Яковлева Татьяна (IP-адрес скрыт)
Дата: 28, January, 2015 15:30

Войдите в БД ЭК и посмотрите словарь предметных рубрик, он у Вас сформирован?

Re: Не пополняется словарь в поле 606
Пользователь: Alt (IP-адрес скрыт)
Дата: 29, January, 2015 08:23

Да, все есть. Скрин прилагаю.

Вложения: 11.jpg (225KB)  
Re: Не пополняется словарь в поле 606
Пользователь: Яковлева Татьяна (IP-адрес скрыт)
Дата: 29, January, 2015 08:59

Какая у Вас версия?

Re: Не пополняется словарь в поле 606
Пользователь: Alt (IP-адрес скрыт)
Дата: 29, January, 2015 09:07

Версия 2014.1 (обновлял строго по инструкции. перестало работать как раз после обновления)

Re: Не пополняется словарь в поле 606
Пользователь: Яковлева Татьяна (IP-адрес скрыт)
Дата: 29, January, 2015 09:17

Вызовете еще раз настройку параметров и нажмите применить

Re: Не пополняется словарь в поле 606
Пользователь: Alt (IP-адрес скрыт)
Дата: 29, January, 2015 09:55

Это было одним из первых моих действий в меню Настройка параметров. Не помогло. Сейчас проделал еще несколько раз. Результата 0.

Если подытожить:

1. Скопировал файл pr31.wss (который из новой версии) из папки Deposite в папку CMPL.

2. В Каталогизаторе выбрал: Сервис - Настройка параметров - БД ЭК для заимствования данных. В поле вручную прописал IBIS (изначально в поле было это же значение).

3. В процессе попыток опустошил и импортировал старую БД IBIS (количество записей в старой БД было больше и, возможно, ее дополняли вручную). После чего выполнил актуализацию и полное пересоздание словаря.

Остальные действия, такие как повторные примененя изменений и т.д., несущественны...

Re: Не пополняется словарь в поле 606
Пользователь: Яковлева Татьяна (IP-адрес скрыт)
Дата: 29, January, 2015 15:24

Возьмите файл pr31.wss для директории CMPL. Вы не взяли присланный мною файл

Вложения: PR31.WSS (2.5KB)  
Re: Не пополняется словарь в поле 606
Пользователь: Alt (IP-адрес скрыт)
Дата: 30, January, 2015 13:07

Появились Предметные подзаголовки. Однако поля "Подзаголовок 1/2/3" остаются пустыми.

В предыдущей версии эти поля можно было заполнять отдельно. Теперь только при выборе "Предметного подзаголовка" появляются "Подзаголовки 1/2/3".

Re: Не пополняется словарь в поле 606
Пользователь: Яковлева Татьяна (IP-адрес скрыт)
Дата: 30, January, 2015 14:42

Возьмите еще раз файл pr31.wss для директории CMPL

Вложения: PR31.WSS (2.6KB)  
Re: Не пополняется словарь в поле 606
Пользователь: Alt (IP-адрес скрыт)
Дата: 02, February, 2015 13:34

Спасибо. Говорят, что все стало хорошо.

Re: Не пополняется словарь в поле 606
Пользователь: KrVs (IP-адрес скрыт)
Дата: 28, February, 2019 08:03

Аналогичная проблема. Не работает словарь предметных рубрик. Всё пустое.

Не работает вот этот код: "@PRIVATE/EKP/IBIS,S=,@!smov"

Вставил другой код, по аналогии с БД IBIS: "IBIS,S=,@!smov", но он тоже не работает. Точнее словарь появляется, но не работает прокрутка. Показывает только самые первые значения, которые умещаются в окно.

Как исправить?

Вложения: error606.jpg (213.2KB)  


Извините, только зарегистрированные пользователи могут писать в этом форуме.
This forum powered by Phorum.